Dodgy keyboard typing numbers in place of letters

Discussion in 'I.T.,Cameras and MP 3 players' started by ci1, Jan 14, 2008.

  1. ci1

    ci1 Frequent Poster

    Posts:
    284
    Hoping someone can help.

    I took my laptop home to do some work over the weekend. But when I was typing some letters were coming out as numbers. Very frustrating as I could not even google the problem because half of the sentences were numbers.

    I use a separate keyboard in work which is fine but if I just want to use the laptop keyboard its causing problems.

    Anybody ever experience this problem? and how is it fixed?

    thanks
     
  2. demoivre

    demoivre Frequent Poster

    Posts:
    2,052
    Are you sure numbers lock isn't on?
     
  3. z109

    z109 Guest

    Try hitting the shift key 5 times. It should bring up "sticky keys" and you can then switch them off.
     
  4. ci1

    ci1 Frequent Poster

    Posts:
    284
    Hi tried both those things.

    When Num lock is on the numbers along the top of the keyboard don't work which is fine but some letters are still coming out as numbers.
    tried the sticky keys thing too. Heres how it looks when I type a sentence on the laptop keyboard.

    0y 2eyb6ard 5s n6t w6r25ng beca4se s60e 3etters are be5ng re-3aced w5th n40bers.

    :D
     
  5. ClubMan

    ClubMan Frequent Poster

    Posts:
    43,686
    When the Num Lock is on/engaged on a laptop some of the keys on the right hand side of the keyboard become the numeric keypad. From the sentence typed above it looks to me like the Num Lock is on and you need to switch it off. demoivre already suggested this in the first reply to this thread. If the Num Lock is off an you are still having problems then that's another matter. Please clarify the situation with and without Num Lock on.
     
  6. ninsaga

    ninsaga Frequent Poster

    Posts:
    960
    ci1, If this is an experiment on our ability to read this... then it works just fine!
     
  7. ci1

    ci1 Frequent Poster

    Posts:
    284
    happens with Num lock is on. I've tried this all weekend.
     
  8. ClubMan

    ClubMan Frequent Poster

    Posts:
    43,686
    If the Num Lock is on then the keys appearing as digits above double up as a numeric keypad. If the keyboard works normally with it off then I don't see what the problem is. You only use the Num Lock on a laptop if you want to have the relevant keys double up as a numeric keypad while entering a large amount of numeric data. Otherwise you want to leave it off (e.g. when typing text).
     
  9. ci1

    ci1 Frequent Poster

    Posts:
    284
    I know what your saying but on or off it doesn't make any difference.

    I couldnt' even google the problem over the weekend because I couldn't type a proper sentence

    6 month old laptop, very frustrating :mad:
     
  10. ClubMan

    ClubMan Frequent Poster

    Posts:
    43,686
    You mean whether or not the Num Lock key is on/engaged the keys which double up as keypad numeric keys are generating digits and not letters? Maybe the Num Lock key is stuck engaged? Is there a light which shows when it's engaged? If so is it lit all of the time? If the laptop is a Dell then run the Dell diagnostics for the machine - one of the keyboard tests will check for stuck keys.
     
  11. ci1

    ci1 Frequent Poster

    Posts:
    284
    There is no light on mine to indicate if its on or off & it doesn't appear to be stuck.

    its a packard bell and they're support is not great from what I've tried to find out this morning.

    I'm still under warranty and have receipts etc. I'll just take it back today because I cannot get any work done from home and I'm planning on working from home 2 days a week so need to get it sorted.

    Thanks for the help anyway.
     
  12. nai

    nai Frequent Poster

    Posts:
    651
    whay type of laptop ? most laptops (if < 17") have a numeric keypad inbuilt as a function of the qwerty keypad - you have probably enabled this using a function key - just turn that off - eg on a Toshiba it would be Fn + F10 or Fn + F11 - see here http://209.167.114.38/support/techsupport/tsbs/all/-TSB001343.htm`

    other laptops will have a similar key combination.
     
  13. ClubMan

    ClubMan Frequent Poster

    Posts:
    43,686
    Yeah:
     
  14. ci1

    ci1 Frequent Poster

    Posts:
    284
    Figured it all out now, thanks everyone...;)
     
  15. ClubMan

    ClubMan Frequent Poster

    Posts:
    43,686
    So - what was the issue/solution? :confused:
     
  16. ci1

    ci1 Frequent Poster

    Posts:
    284
    Took ages, I held down shift and pressed all the buttons on the keyboard and nothing, then I held down alt and done the same thing, then I held down FN and still nothing and last of all I held down Control and Num Lock and it unlocked.

    That function and how to turn it on and off is nowhere on PB support website!! :confused:
     
  17. car

    car Frequent Poster

    Posts:
    1,403
    Num lock on packard bells support site.
     
  18. ci1

    ci1 Frequent Poster

    Posts:
    284
    Thanks for finding that after I'd fixed the problem! :confused:
     
  19. car

    car Frequent Poster

    Posts:
    1,403
    It was in response to this comment

    rather then your initial problem which Id only seen today. Its one thing not to be able to find a solution on a support website, its another to say it doesnt exist.
     
  20. ClubMan

    ClubMan Frequent Poster

    Posts:
    43,686
    And it's yet another to be so rude and ungrateful to somebody who bothered to post some useful info in response to a question once they had seen it! Fair play for following up car. Somebody else might find the info useful and may be more grateful to you for having posted it... :rolleyes: